Announcement

Collapse
No announcement yet.

ROS Indigo and Ubuntu 14.04LTS

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • ROS Indigo and Ubuntu 14.04LTS

    I wanted to start a thread to colledt tips regarding the installation of Robotino ROS software on Ubuntu 14.04. and ROS Indigo, since we just switched to that configuration and hopefully get everything up and running again.

    First thing:
    Catking-Packages don't build without

    1. installing nav-core package (apt-get install ros-indigo-nav-core)

    2. installing the Robotino API2 (examples not necessary): http://wiki.openrobotino.org/index.p...PI2_quickstart

    3. changing robotino_node/CMakeLists.txt to include the API folder "/usr/local/robotino/api2" (I don't know why it wasn't recognized before):
    Code:
    include_directories(
      include
      ${catkin_INCLUDE_DIRS}
      /usr/local/robotino/api2
    )
    Following those steps I could successfully compile the catkin packages. The rosbuild-stuff worked out of the box as far as I remember.

    EDIT
    The last step only seems to be necessary on some systems. Normally it works without this modification.
    Last edited by misken; 06-06-2016, 07:41 AM.

  • #2
    Additional note:
    On the Robotino itself it was only necessary to install the nav-core package, the rest built without errors. So the steps mentioned above might be specific to my configuration (though it was a completely fresh install of Ubuntu 14.04).

    Comment


    • #3
      Hi!

      I have problems compiling in Ubuntu 14.04 in ROS indigo, the full thread here if you can help me: http://forum.openrobotino.org/forum/...o-ubuntu-14-04

      Comment


      • #4
        We now updated the ROS packages to enable the digital IO ports control via ROS and added support for the relays. They can be used as follows (just a manual example):
        Code:
        rostopic pub -1 /set_relay_values robotino_msgs/DigitalReadings -- '[0, 0]' '[bool, bool]‘
        rostopic pub -1 /set_digital_values robotino_msgs/DigitalReadings -- '[0, 0]' '[bool, bool, bool, bool, bool, bool, bool, bool]‘
        The first array includes the time (which is set to 0 in this case), the second one a boolean array to control the ports. It is possible to reduce the number of booleans (the are evaluated one after another, if there are less booleans than ports, the last ports are unchanged). E.g.:
        Code:
        rostopic pub -1 /set_relay_values robotino_msgs/DigitalReadings -- '[0, 0]' '[bool]‘
        only controls the first realy. As you can see it is not possible to control the second relay without the first.

        To use it you need the extended robotino_node from https://github.com/UniOL-AMT/uol-robotino-ros-indigo

        Comment


        • #5
          Hi,
          I am very new to ROS and robotino. I have to work on study project using Robotino. I tried to compile the code
          But I am getting error releated to robotinoAPI2.
          I am running this in my laptop. I am not sure do i need to compile this in Robotino or not.? Can you please help regarding this issue please?
          Thank You.

          Comment


          • #6
            Hi rasoo,

            when did you check out the files? There was an error with some SVN changes but this should be resolved. But I can imagine that there are some other changes that we didn't come across so far. Can you please post the error messages you get?

            It's best to compile this on both laptop and robotino. Then you have all options. In the end it depends on which configuration you want to use. Normally it is easier to run robot-hardware-related code on the robot itself because then you also have access to the hardware ports etc. To just move the robot around it is sufficient to just use it on a laptop since all commands are transferred via RPC. But you need to change the IP in the launchfiles then.

            Comment


            • rasoo
              rasoo commented
              Editing a comment
              Heyii I figure out the problem and it was related to API2 installation. I solved the problem and now I can compile it successfully. Thank you sooo very much for your solution and also for the supportive response. I check out 2 days ago.
              Thank you.
              Last edited by rasoo; 06-06-2016, 11:37 AM.
          Working...
          X