Announcement

Collapse
No announcement yet.

Ubuntu 14.04

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ubuntu 14.04

    Ubuntu 14.04 on Robotino3

  • #2
    I am just putting together a new image for Robotino based on Ubuntu 14.04. This makes installing ROS a lot easier. I rebuild everything linking to Qt5 now which is the default Qt version for Ubuntu 14.04. There still might be some bugs but I would appreciate if you could install and test the new image.

    http://doc.openrobotino.org/download...ino3-2.0.2.fsa

    Look into the wiki on how to install the image to Robotinos mSATA-SSD drive.

    Comment


    • #3
      Hi!
      I just installed the new image on our quite new Robotino 300.235. First impressions:
      - There are a few lines "error: file not found" followed by "please press any key to continue" right after the grub boot screen, but after a few seconds the boot process goes on.
      - The LAN network interfaces are gone. Neither eth0 nor eth0.10 are present any more. WiFi is woking as usual.

      Output from ifconfig:
      Code:
      robotino@robotino:~$ ifconfig
      lo        Link encap:Lokale Schleife
                inet Adresse:127.0.0.1  Maske:255.0.0.0
                inet6-Adresse: ::1/128 Gültigkeitsbereich:Maschine
                UP LOOPBACK RUNNING  MTU:65536  Metrik:1
                RX-Pakete:1820 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
                TX-Pakete:1820 Fehler:0 Verloren:0 Überläufe:0 Träger:0
                Kollisionen:0 Sendewarteschlangenlänge:0
                RX-Bytes:152228 (152.2 KB)  TX-Bytes:152228 (152.2 KB)
      
      wlan0     Link encap:Ethernet  Hardware Adresse 08:bd:43:88:f8:41
                inet Adresse:172.26.1.1  Bcast:172.26.255.255  Maske:255.255.0.0
                inet6-Adresse: fe80::abd:43ff:fe88:f841/64 Gültigkeitsbereich:Verbindung
                UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
                RX-Pakete:5167 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
                TX-Pakete:2980 Fehler:0 Verloren:0 Überläufe:0 Träger:0
                Kollisionen:0 Sendewarteschlangenlänge:1000
                RX-Bytes:1341879 (1.3 MB)  TX-Bytes:1303755 (1.3 MB)
      I will try to have a closer look today if there is time. If you want to have any log output let me know.


      EDIT
      It seems, that the interface naming has changed, an ifconfig -a resulted in a third device:
      Code:
      em1       Link encap:Ethernet  Hardware Adresse 00:19:0f:16:db:bc
                BROADCAST MULTICAST  MTU:1500  Metrik:1
                RX-Pakete:0 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
                TX-Pakete:0 Fehler:0 Verloren:0 Überläufe:0 Träger:0
                Kollisionen:0 Sendewarteschlangenlänge:1000
                RX-Bytes:0 (0.0 B)  TX-Bytes:0 (0.0 B)
                Interrupt:20 Speicher:fe600000-fe620000
      which I could change back to eth using this information: http://ubuntuforums.org/showthread.php?t=2150517 by changing one line in /etc/default.grub
      Code:
      GRUB_CMDLINE_LINUX_DEFAULT="biosdevname=0"
      and running sudo update-grub afterwards. Now both eth0 and eth0.10 are back.
      Last edited by misken; 05-11-2015, 02:23 PM.

      Comment


      • #4
        At every login I get this message:
        Last login: [...]
        -bash: export: `/usr/lib/jvm/java-7-openjdk-amd64/': Ist kein gültiger Bezeichner.

        Comment


        • #5
          The error from the previous post can be resolved by editing ~/.profile, there is a missing = after JAVA_HOME:
          JAVA_HOME /usr/lib/jvm/java-7-openjdk-amd64/
          should be
          JAVA_HOME=/usr/lib/jvm/java-7-openjdk-amd64/

          Comment


          • #6
            I just updated the robotino packages via apt-get (see log)
            Code:
            upgrade robotino-api2:amd64 1.0.0 1.0.1
            upgrade robotino-config:amd64 0.9.11 1.0.0
            upgrade robotino-daemons:amd64 1.0.0 1.0.1
            upgrade robview3:amd64 3.1.0 3.1.0
            and controld3 was not starting any more. Starting it by hand resulted in
            Code:
            /usr/local/robotino/daemons/bin/controld3
            10:44:54.657 | Not using internal gyro for odometry
            10:44:54.657 | Using external gyro for odometry/usr/local/robotino/daemons/bin/controld3: symbol lookup error: /usr/local/robotino/daemons/bin/controld3: undefined symbol: _ZN3rec8robotino3rpc6Client42set_rec_robotino_rpc_gyroscope_ext_enabledEb
            It seems that the configuration is changed to use an external gyro by default which is not present at our robots. I would suggest to make the default setting to no gyro at all.
            Changing the settings via web interface resolved the error.

            Comment


            • #7
              Can anyone help me?

              Im trying to install this in robotino 300 but Im getting this messaje:

              mount: /dev/sdb1 is not a valid block device

              This is my original post:


              http://forum.openrobotino.org/forum/...buntu-14-image

              Comment

              Working...
              X