Announcement

Collapse
No announcement yet.

Connection problem with robotinos

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Connection problem with robotinos

    Hello,

    As I am new to Robotino, I will probably ask a lot of questions in here the following weeks
    I have now 3 Robotinos installed and configured. However, there is a problem with the connection of two Robotinos which seems to have overwritten IP addresses.
    I can connect to Robottino 14 with IP 172.21.14.90 on the webinterface and control the robot from there. If I want to connect to Robotino 16 with IP 172.21.16.90 on the webinterface, then I get an infinite wait message. On the other hand, when I go to the Robotino Factory and I try to connect to 172.21.14.90. Then I see a map with only Robotino 16. There I can control Robotino 16 but not Robotino 14. If I try to connect to 172.21.16.90 in the Factory program, then nothing works. If I try to have remote access to both via VNC, then this works for both. And if I enter the 'ifconfig' command in both terminals, then I get the right IP address. So in some way, Robotino Factory thinks that Robotino 16 is on IP 172.21.14.90. (BTW, in the settings of Robotino 14, the master IP is 172.21.14.90) I already removed this Factory program and reinstalled it again, but I have the same problem. Also the webinterface can still not connect to IP 172.21.16.90. If I change something in the settings of Robotino 14 with IP 172.21.14.90, of which I do have access on the webinterface, then both Robotino 14 and 16 restart.
    Can someone help me with this please?

    Regards,
    Matthias

  • #2
    One Robotino has to be configured as master and the other Robotinos need to connect to the master. Only the master runs the smartsoft-master components. The other Robotinos only run the smartsoft-slave components.

    Comment


    • #3
      Yes I know, but for some reason, I like them all to be their own master, which works fine. The problem was that some IP addresses were overwritten inside Robotino 16. I don't know how this happened. So I connected virtually via VNC and dived into the etc/ files where I could change the IP addresses. Now everything works fine and all the robots have their own map. The only thing that is still not working is the access to the webpage of Robotino 16. I can control it via the Factory and remote, but not on the webpage.

      Comment

      Working...
      X