Announcement

Collapse
No announcement yet.

Robotino 2 - Simulink - ROS - API2

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Robotino 2 - Simulink - ROS - API2

    I am trying to use an old Robotino v2 (500MHz AMD Geode) with ROS but I also need Simulink for parts of the project.
    I updated to API 2, ROS seems to be working after initial testing. Matlab toolbox odometry works, but when I try to use the blockset example example_simulink_RobotinoHardware.mdl the odometry is not providing anything and the simulation keeps running but the robot stops after a short while. It was working fine on API1.
    The versions that work and are in use are 0.9.13 for api2 on the Matlab/Simulink PC. I am using api2 0.9.13 on the robotino, and tried with all the latest versions of the deb packages. Not only did it not solve the Simulink problem but using the latest common and daemons break the voltage indicator/meter on the robot, so I am currently using the previous versions - 0.7.3 for common and 0.7.6 for daemons.
    Can someone provide any advice on how to use Simulink (the odometry specifically) with API2?

  • #2
    Please check if the odometry topic is published. Login to Robotino as root and invoke the command
    Code:
    robtopic echo odometry
    Does it give you any output?

    Please try reading the odometry from Matlab by using the m-files (plain Matlab not Simulink). Does this work?

    Regards
    Christian

    Comment


    • #3
      Yes, the odometry topic is published and updated. ROS is running on my laptop not on the Robotino itself by the way. The odometry in Matlab is also working fine I checked with a simple m-file (I cannot attach m-files apparently). In simulink though the odometry is not updating - it changes from 0 to a value once or maybe twice, doesn't give any error but doesn't update, also even though the simulation is set to Inf motion stops after some time.

      Comment


      • #4
        I also tested with Simulink and found that there is this problem you reported with newer versions of Matlab. With older versions it worked fine. So it is an Matlab/Simulink specific issue. I do not hae any idea why it is not working anymore and Simulink does not report anything. Just stops processing.

        Comment


        • #5
          It was reported on the forum for versions upwards of 2016a I am using 2013 and it was working fine with the API1. Which leads me to believe that is should not be on the MatLab/Simulink end. How much older versions should be used? Is there someone working on the problem?

          Comment


          • #6
            Are you going to provide any additional info?

            Comment


            • #7
              I kindly bump the thread hoping a Festo support person will add more information.

              Comment

              Working...
              X