Announcement

Collapse
No announcement yet.

Distance Sensor issues.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Distance Sensor issues.

    Hello everyone:

    I have issues to read the voltage signal from the distance sensor. I'm currently working with Labview and the blocks library was working "fine" enough. When I run the VI i get the heading in data very well but 0 v from the voltage. I updated the robotino os with the images found in the wiki, but there's no change at all. Does anyone have the same problem? can you read voltage easily? Any advice?

    I appreciate any help that you can provide

    Soul

  • #2
    I cannot really help in this case but this might lead to a solution: in ROS, reading the voltage was broken too. This was because there was an API change (I guess) which was not reflected in the ROS drivers for Robotino. I suggest that this might be the issue here as well. If the Labview block uses the old API call then it doesn't work. Anyhow I regret that I don't know how to check or change Labview blocks.

    Comment


    • #3
      Make sure your Robotino OS and the LabView toolbox match. From the download section on wiki.openrobotino.org you can get the v2.4 image for your Robotino2. This matches the LabView toolbox v1.1.0.

      Comment


      • #4
        Thanks you so much, guys.

        All your comments make a lot of sense.

        I was in fact trying to go back to an older robotino version but now i'm gonna try with 1.1.0.

        I'll let you know how everything is going.

        Comment


        • #5
          I've just tried but I have no response. I was trying to use laser finder too, but I can't access to that function either.

          Maybe I need to change to a different version of the CF image,

          If anyone has another hint , I will be grateful.

          Thanks.

          Soul

          Comment


          • #6
            Hi....i think there is a variable to set the port on which the ultrasonic sensor is connected on line 44 there.
            Can you try both the digital and analog ports and see if it works for you.

            pcb assembly
            Last edited by JardCrocker; 12-22-2017, 07:36 PM.

            Comment

            Working...
            X