Announcement

Collapse
No announcement yet.

Robotino2 in Client mode with router as an external access point

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Robotino2 in Client mode with router as an external access point

    Hi all,

    previously we have been successfully using robotinos in client mode via wireless external access point. However, after a couple of months of break in using robotinos, I tried to run some ROS mapping but I could not get the robotino connected via wlan. (Everything works fine when connecting the robotino to the network via ethernet cable - i.e., robotino still in the client mode).

    The network settings are as follows:
    via 2-line LCD:
    ethernet: some static IP
    wlan:
    WPA:
    ssid <- ssid as defined by the router (external AP)
    psk <- password as defined by the router (external AP)
    proto <- WPA - as defined by the router (external AP)
    pairwise <- TKIP - as defined by the router (external AP)
    group <- TKIP

    After the above wlan settings, when I try to activate the DHCP. The lcd displays:
    ifdown wlan0
    ifup wlan0
    Failed to bring success

    Additionally, after every restart, these wlan settings seem to be vanished. And, it seems they are not visible by the Robotino OS. After I run ifconfig directly on Robotino PC104 using an external monitor and keyboard, I only see a ethernet connection.

    Am I doing something wrong in configuring the Robotino's WLAN? Should I be able to configure WLAN from Robotino OS? (As it does not seem to recognize any wireless network adaptors, when I run 'lshw -C network')

    Best regards,
    Omer
Working...
X