Announcement

Collapse
No announcement yet.

Robotino Factory API2 Daten leer

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • verbeek
    replied
    Also bei mir funktioniert es. Muss bei Dir also auch gehen. lasertype ist jetzt über die ComboBox hokuyoURG ausgewählt? Dann neu gestartet?

    Leave a comment:


  • Bins_Net
    replied
    Ist über USB angeschlossen.

    Leave a comment:


  • verbeek
    replied
    Ist der Laserscanner per USB oder Ethernet angeschlossen?

    Leave a comment:


  • Bins_Net
    replied
    Hat leider auch nichts gebracht.
    Weiterhin bekommen wir in der RobotinoView sowie auch aus der API2 Daten von den Laserscanner.

    Leave a comment:


  • verbeek
    replied
    lasertype -> hokuyoURG

    Leave a comment:


  • Bins_Net
    replied
    Bei LaserDevice war in der neuen Firmwareversion /dev/ttyS5 vorkonfiguriert.
    Ich habe testweise manuell /HokuyoURG eingetragen
    In der Factory Version 2.5.0 funktioniert der Laserscanner bei uns leider trotzdem nicht. Sowohl auf der Version auf den Laptop als auch in der Factory die in der Firmware auf den Robotino mitinstalliert wurde.
    In der RobotinoView sowie auch aus der API2 bekommen wir Daten von den Laserscanner.


    Leave a comment:


  • verbeek
    replied
    Ichbin nicht Festo und habe keinen Einblick in die Kundendaten. Was steht bei Ihnen in /etc/robotino/smartsoft_slave.conf? Ist dort HokuyoURG ausgewählt?

    Leave a comment:


  • Bins_Net
    replied
    Der Standard Robotino3 Laserscanner. Müsste der sein.

    https://www.festo-didactic.com/de-de...E4Ljg1OC43NzQy

    Wir sind Schüler an der Technikerschule Erlangen vll haben Sie ja Einblick auf die Kundendaten.

    Schöne Grüße

    Leave a comment:


  • verbeek
    replied
    Was für ein Laserscanner?

    Leave a comment:


  • Bins_Net
    replied
    Hallo,

    haben nun die Version 4.0.9-smartsoft-2.5.0 aufgespielt.

    Wir können uns mit der Factory 2.5.0 verbinden der Laserscanner liefert aber in der Factory kein Signal mehr. Über die API2 bekommen wir Daten von den Laserscanner nur in der Factory nicht. Die Landkartenerstellung fuktioniert somit leider wieder nicht.

    Schöne Grüße
    Last edited by Bins_Net; 02-13-2020, 12:10 PM.

    Leave a comment:


  • verbeek
    replied
    Das einfachste für mich wäre, wenn Du das gestern erstellte Image aufspielst

    4.0.9-smartsoft-2.5.0

    Das funktioniert nur mit Robotino Factory 2.5.0. Dann noch mal versuchen und wenn es immer noch nicht funktioniert, dann müssen wir mal AnyDesk bemühen.

    https://wiki.openrobotino.org/index....botino3_images

    Leave a comment:


  • Bins_Net
    replied
    172.26.1.1 vermute ich ich schaue das morgen mal nach. Die Verbindung zu den Robotino aus der Factory heraus funktioniert auch. Der Robotino ist auch steuerbar über die Factory. Ich kann auch die Funktion des Laserscanners in der Factory sehen.
    Nur bei der Landkartenerstellung unter create new map zeichnet er keine Landkarte auf und lässt mich diese auch nicht speichern.
    Ich komme in das Menü zum erstellen einer neuen Karte nur in diesen Menü wird sie dann nicht wie gewohnt aufgenommen.....
    Ich habe auch verschiedene Versionen der Robotino Factory getestet in jeder habe ich das selbe verhalten.

    Leave a comment:


  • verbeek
    replied
    in smartsoft_slave.conf muss die IP-Adresse des Robotino eingetragen werden, über die man Robotino von der Factory aus erreichen kann. Was steht da bei Ihnen? Zu welcher IP verbinden Sie sich mit der Factory?

    Leave a comment:


  • Bins_Net
    replied
    bzw. müssen wir evtl. in der Robotino smartstoft_master.conf bzw. in der Robotino smartsoft_slave.conf etwas konfigurieren?

    Leave a comment:


  • Bins_Net
    replied
    Hallo,

    wir haben jetzt auf den Robotino die Version robotino4-4.0.8-smartsoft-2.4.7 installiert. Dazu haben wir den TP-Link-AC750 bestellt.
    Wir haben noch folgenden Befehl ausgeführt damit sich der Robotino nicht sofort herunterfährt wenn man den Bildschirm trennt:

    > Change Lid Close Action
    > echo "HandleLidSwitch=ignore" >> /etc/systemd/logind.conf
    > systemctl restart systemd-logind.service

    Es funktioniert soweit nur folgendes Problem haben wir jetzt:

    Wir können mit der Robotino Factory keine Landkarte erstellen. Wir können uns mit den Robotino über die Factory verbinden, können ihn Steuern aber unter create new map macht er keine Aufzeichnungen der Karte. Der Laserscanner funktioniert in der Factory. Speichern der Karte funktioniert leider auch nicht. Haben Sie eine idee?

    Anbei ein Screenshot un das Verhalten besser darstellen zu können. Es wurden diverse Factory Versionen probiert. Das Verhalten ist leider überall identisch.

    Leave a comment:

Working...
X