Announcement

Collapse
No announcement yet.

Missing rec_robotino_api2_java_wrapper.dll

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Missing rec_robotino_api2_java_wrapper.dll

    Hallo zusammen,

    beim Starten meines Java Robotino Programmes erhalte ich folgenden Fehler:

    Exception in thread "main" java.lang.UnsatisfiedLinkError: Can't load library: C:\Program Files\REC GmbH\robotino\api2\bin\rec_robotino_api2_java_wrap per.dll
    at java.lang.ClassLoader.loadLibrary(Unknown Source)
    at java.lang.Runtime.load0(Unknown Source)
    at java.lang.System.load(Unknown Source)
    at rec.robotino.api2.RobotinoLibraryLoader.loadLibrar ies(RobotinoLibraryLoader.java:29)
    at rec.robotino.api2.Com.<clinit>(Com.java:55)
    at Robotino.<init>(Robotino.java:21)
    at Robotino.main(Robotino.java:133)


    Ich habe auch mehrmals versuch die 64bit API2 neu zu installieren und das ohne erfolgt. Von wo kann ich die "rec_robotino_api2_java_wrapper.dll" erhalten bzw. wie kann ich diesen Fehler beheben?

    Viele Grüße und Danke!

  • #2
    Hallo,
    wir hatten in der Vergangenheit immer wieder viele Probleme mit dem Java-Wrapper um die C++-Bibliothek rec_robotino_api2. Aus diesem Grund haben wir aufgehört den Java-Wrapper zu verteilen und statt dessen Robotino mit einem REST-API ausgestattet.
    https://wiki.openrobotino.org/index.php?title=Rest_api
    Von Java aus ein REST-API zu bedienen ist wohl ziemlich einfach. Ich bin selbst kein Jaba Experte, habe aber z.B. das gefunden
    https://alvinalexander.com/java/java...lient-examples

    Das REST-API bekommst Du mit der neusten Version des robotino-daemons Paketes
    https://wiki.openrobotino.org/index....le=Robotino_OS

    Da haben sich die Abhängigkeiten verändert, so dass zunächst ein komplette löschen der alten Pakete sinnvoll sein kann
    dpkg -P robotino-daemons
    dpkg -P robotino-common

    und erst dann
    apt-get update
    apt-get install robotino-daemons

    Ansonsten kannst Du auch das Beta-Image
    https://doc.openrobotino.org/downloa...ino4-4.0.0.fsa
    installieren

    Comment


    • #3
      Brandneues Image 4.0.1 (zwei Dateien) mit Ubuntu 18.04. Hat natürlich auch die neusten Pakete mit REST-API
      https://doc.openrobotino.org/downloa...obotino4image/

      Comment

      Working...
      X